当前位置:首页 > 文章资讯 >

【漏洞预警】fastjson < 1.2.66 反序列化远程代码执行漏洞

发布时间::2020-03-17 10:07    浏览161次

近日,阿里云应急响应中心监测到fastjson官方git披露fastjson存在最新反序列化远程代码执行漏洞攻击Gadgets,利用该最新的Gadgets,攻击者可远程执行服务器任意命令,继而控制服务器权限,风险极大。官方已发布最新版本1.2.66修复该漏洞,请使用到fastjson的用户尽快升级至安全版本。


漏洞描述

fastjson采用黑名单的方法来防御反序列化漏洞,导致当黑客不断发掘新的可攻击的反序列化Gadgets类时,则可轻松绕过黑名单防御机制,反序列化漏洞就会再次出现。fastjson自1.2.5X以上默认关闭autotype,默认配置不受漏洞影响。阿里云应急响应中心提醒fastjson用户尽快采取安全措施阻止漏洞攻击。


影响版本

fastjson < 1.2.66


安全版本

fastjson >= 1.2.66

fastjson自1.2.5X版本以上默认关闭autotype,默认配置不受漏洞影响


安全建议

升级至安全版本,参考下载链接:https://repo1.maven.org/maven2/com/alibaba/fastjson/


相关链接

https://github.com/alibaba/fastjson/releases/tag/1.2.66



阿里云云安全中心应急漏洞模块已支持对该漏洞一键检测

阿里云云防火墙已可防御此漏洞攻击

阿里云漏洞扫描已支持对该漏洞检测

阿里云WAF默认防御此漏洞攻击


关注排行榜more

最新收录more